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Figure 7-5. - NIMS 27 temperature data displayed simultaneously with PPR 24 IS data. 
 

7.2.4. PPR 

Most of the accuracy issues with regards to the PPR datasets involve the actual data 
collection itself.  Throughout the three datasets, eleven negative temperature values were 
found and excluded from this project.  The cause of these anomalies is still unknown.  
Another potential issue arises when comparing daytime and nighttime observations 
because the average temperatures between the two observations will be tremendously 
different.  These differences between observations are rather apparent when comparing 
the daytime observations of 24IN to the nighttime observations of 27 IN.  As displayed in 
Figure 7-6, the two were classified using the same scheme and display remarkable 
differences in temperatures over the same area.   
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Figure 7-6. - PPR 24 IN day observations compared to 27 IN night observations. 

 

These differences in temperature are also considered when the statistical surfaces were 
created for the PPR data.  Although these surfaces are just a statistical estimation of 
temperatures over areas where data was not collected, it is important to know that 
variations in surface temperature are present.   

7.3. Future Directions 
This project was essentially responsible for prototyping a system and methods for 
transforming Galileo spacecraft data into GIS.  The efficiency of the overall direction of 
this project is highly dependent on the satisfaction and commitment of the Io research 
community to pursue this any further.  There are most likely unseen improvements that 
can be made immediately to some of the aspects of the project by advanced GIS users 
and Io researchers.  Once the Io research community is satisfied with the outcome and 
management of the system in place, data transformation and inventory of additional 
datasets can commence.   

The basic foundation for data transformation is a set for researchers to begin transforming 
the massive amounts of data that exist within the Io data libraries.  All of the datasets 
listed within this project are simply subsets of the vast quantity of data captured by the 
Galileo spacecraft during its mission.  Numerous other SSI, NIMS, and PPR datasets 
could be processed within a minimal amount of time and added to the database.  The 
system is essentially open to any additional datasets that may become available such as 
the geologic maps currently being produced by different researchers around the country.  
The initial learning process and amount of time required to initialize researchers to 
further their work will be strenuous, but the information they could possibly gain from 
compiling all of their data into a system that could be manipulated could produce 
invaluable results. 
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Appendix A – Global Mosaic Processing Flow Chart & Description 
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1. Import the Image file  
 - Platform: ENVI 4.2 

 - Method: File -> Open Image File 

2. Apply Linear Stretch (For Color Mosaic Only) 

 - Platform: ENVI 4.2 

 - Method: Enhance -> [Image] Linear 0-255 

3. Perform a Resolution Merge (For Resolution Merge Dataset Only) 

 - Platform: ENVI 4.2 

 - Method: Transform -> Image Sharpening -> HSV 

  - Select Input RGB (GLL_color_Simp_Clon180_8bit.tif) 

  - Select High Resolution Input (Io_SSI_VGR_bw_Equi_Clon180_8bit.tif) 

4. Export as Spatial Subsets 
 - Platform: ENVI 4.2 

 - Method: File -> Save Image As -> Image File  

  - Spatial Subset – Adjust Samples (eg. Change 11445 to 5723) 

  - Output File Type – TIFF/GeoTIFF 

5. Open Registering.mxd  

 - Platform: ArcGIS 9.1 

 - Method: File -> Open 

6. Open VBA Script 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Macros -> Visual Basic Editor 

  - Select RegisterMosaics - Ensure data path and filename are appropriate 

NOTE!! – If the file that is going to be created already exists in the selected directory, the 
program will not execute. 

7. Run RegisterMosaics Module 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Macros -> Macros -> RegisterMosaics 

8. Import Spaital Subsets 
 - Platform: ArcGIS 9.1 

 - Method: File -> Add Data… 

9. Add Georeferencing Toolbar 
 - Platform: ArcGIS 9.1 
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 - Method: View -> Toolbars -> Georeferencing 

10. Georeference Mosaics to Points 
 - Platform: ArcGIS 9.1 

 - Method: Georeferencing Toolbar Buttons 

  - Set Layer: to mosaic needed to be georeferenced 

  - Add Control Points Button 

   - First select corner of image 

   - Second select corresponding point of MosaicPoints.shp 

11. Export Georeferenced Image 
 - Platform: ArcGIS 9.1 

 - Method: Right-Click File in Table of Contents -> Data -> Export Data… 

  - Spatial Reference – Data Frame (Current) 

  - Output Raster - Use Renderer – Check 

  - Format - TIFF 

12. Apply Linear Stretch (Display for Color Mosaics) 

 - Platform: ArcGIS 9.1 

 - Method: Right-Click File in Table of Contents -> Properties -> Symbology 

  - Stretch – Type – None 
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Appendix B – SSI Processing Flow Chart & Description 
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program 
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13. Apply Linear 
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1. Run amarani.pro program  
 - Platform: ENVI 4.2 – IDL 6.2 

 - Method: File -> Open  

 - Method: Run -> Compile amarani.pro 

 - Method: Run -> Run amarani 

2. Import Image from IDL Variable  
 - Platform: ENVI 4.2  

 - Method: File -> Import from IDL Variable 

  - Select Import Variable: IMG: Floating Point Array (1225x793) 

 - Method: Load Band 

3. Scale the Image  

 - Platform: ENVI 4.2  

 - Method: Basic Tools -> Band Math 

  - Equation: fix(((float(b1) – min)/range)*255) 

   - eg. fix(((float(b1) – (-100))/425.786591)*255) 

4. Export the Image 
 - Platform: ENVI 4.2 

 - Method: File -> Save Image As -> Image File  

  - Output File Type – TIFF/GeoTIFF 

5. Open Registering.mxd  
 - Platform: ArcGIS 9.1 

 - Method: File -> Open 

6. Import SSI Image & Global Mosaic 
 - Platform: ArcGIS 9.1 

 - Method: File -> Add Data… 

7. Open VBA Script 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Macros -> Visual Basic Editor 

  - Select RegisterSSI - Adjust data path, filename, and coordinates  

NOTE!! – If the file that is going to be created already exists in the selected directory, the 
program will not execute. 
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8. Run RegisterSSI Module 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Macros -> Macros -> RegisterSSI 

9. Add Georeferencing Toolbar 
 - Platform: ArcGIS 9.1 

 - Method: View -> Toolbars -> Georeferencing 

10. Georeference SSI Image to Points 
 - Platform: ArcGIS 9.1 

 - Method: Georeferencing Toolbar Buttons 

  - Set Layer: to SSI image needed to be georeferenced 

  - Add Control Points Button 

   - First select corner of image 

   - Second select corresponding point of SSIPoints.shp 

NOTE: Original Image needed to be vertically flipped to match Global Mosaic 

11. Georeference SSI Image to Global Mosaic 

 - Platform: ArcGIS 9.1 

 - Method: Georeferencing Toolbar Buttons 

  - Set Layer: to SSI image needed to be georeferenced 

  - Add Control Points Button 

   - First select point on SSI image 

   - Second select corresponding point on Global Mosaic 

 - Method: Georeferencing -> Transformation -> 3rd Order Polynomial 

12. Export Georeferenced Image 
 - Platform: ArcGIS 9.1 

 - Method: Right-Click File in Table of Contents -> Data -> Export Data… 

  - Spatial Reference – Data Frame (Current) 

  - Output Raster - Use Renderer – Check 

  - Format - TIFF 

13. Apply Linear Stretch (Display) 

 - Platform: ArcGIS 9.1 

 - Method: Right-Click File in Table of Contents -> Properties -> Symbology 

  - Stretch – Type – None 
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Appendix C – NIMS Processing Flow Chart & Description 
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1. Run amarani.pro program  
 - Platform: ENVI 4.2 – IDL 6.2 

 - Method: File -> Open  

 - Method: Run -> Compile amarani.pro 

 - Method: Run -> Run amarani 

2. Import Image from IDL Variable  
 - Platform: ENVI 4.2  

 - Method: File -> Import from IDL Variable 

  - Select Import Variable: NIMSIMG: Floating Point Array (48x54x15) 

  - Select Import Variable: NIMS27IMG: Floating Point Array (86x136x15) 

 - Method: Load Band 

3. Export the Image (For Original Images Only) 

 - Platform: ENVI 4.2 

 - Method: File -> Save Image As -> Image File  

  - Output File Type – ERDAS IMAGINE 

4. Run tempfit.pro (or tempfit27.pro) program (For Temperature Datasets Only) 

 - Platform: ENVI 4.2 – IDL 6.2 

 - Method: File -> Open  

 - Method: Run -> Compile tempfit.pro 

 - Method: Run -> Run tempfit 

5. Convert Image to Integers (For Temperature Datasets Only) 

 - Platform: ENVI 4.2  

 - Method: Basic Tools -> Band Math 

  - Equation: fix(b1) 

6. Export the Image (For Temperature Datasets Only) 

 - Platform: ENVI 4.2 

 - Method: File -> Save File As -> ASCII  

  - Output Style – ESRI ASCIIGRID 

7. Open Registering.mxd  
 - Platform: ArcGIS 9.1 

 - Method: File -> Open 

8. Import NIMS Image & Global Mosaic 
 - Platform: ArcGIS 9.1 
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 - Method: File -> Add Data… 

9. Open VBA Script 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Macros -> Visual Basic Editor 

  - Select RegisterNIMS2X - Adjust data path, filename, and coordinates  

NOTE!! – If the file that is going to be created already exists in the selected directory, the 
program will not execute. 

10. Run RegisterNIMS2X Module 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Macros -> Macros -> RegisterNIMS2X 

11. Add Georeferencing Toolbar 

 - Platform: ArcGIS 9.1 

 - Method: View -> Toolbars -> Georeferencing 

12. Georeference NIMS Image to Points 
 - Platform: ArcGIS 9.1 

 - Method: Georeferencing Toolbar Buttons 

  - Set Layer: to NIMS image needed to be georeferenced 

  - Add Control Points Button 

   - First select corner of image 

   - Second select corresponding point of NIMS2XPoints.shp 

NOTE: Original Images needed to be rotated 180º to match Global Mosaic 

13. Export Georeferenced Image 

 - Platform: ArcGIS 9.1 

 - Method: Right-Click File in Table of Contents -> Data -> Export Data… 

  - Spatial Reference – Data Frame (Current) 

  - Output Raster - Use Renderer – Check 

  - Format – IMAGINE Image 
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Appendix D – PPR Processing Flow Chart & Description 
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1. Import the .geo or .rad File in WordPad 
 - Platform: Microsoft WordPad 

 - Method: File -> Open… 

  - Files of Type – All Documents (*.*) 

2. Remove the Header Information (First Two Lines) and Save 

 - Platform: Microsoft WordPad 

 - Method: Keyboard: Delete 

 - Method: File -> Save As… 

  - Save as Type – Text Document 

3. Import and Save the .geo or .rad WordPad File in Excel 

 - Platform: Microsoft Excel 

 - Method: File -> Open… 

  - Files of Type – All Files (*.*) 

  - Original Data Type – Delimited – Check 

  - Delimiters – Space - Check 

 - Method: File -> Save As… 

4. Join .geo and .rad Tables 

 - Platform: Microsoft Excel 

 - Method: Copy -> Paste 

5. Remove any Records with Negative Temperature Values 
 - Platform: Microsoft Excel 

 - Method: Data -> Sort 

  - Sort by – T(K) 

  - Ascending - Check 

 - Method: Select Row -> Right-Click -> Delete 
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6. Add and Calculate Location and Ellipse fields 
 - Platform: Microsoft Excel 

 - Method: Insert -> Columns 

 - Field Name - NEWLON 

  - Equation: =360-LON 

  - Field Name - NEGLON 

   - Equation: =LON*(-1) 

  - Field Name – NEWSSCLON 

   - Equation: =360 - SSCLON 

- Field Name – WIDTH_KM 

   - Equation: =SIPDIS*TAN((2.5/2)/1000) 

- Field Name – WIDTH_D 

   - Equation: =((WIDTH_KM/1815)*180)/PI() 

- Field Name – ADJ_WID_D 

   - Equation: =(ACOS((COS(WIDTH_D*PI()/180)-
SIN(LAT*PI()/180)*SIN(LAT*PI()/180))/(COS(LAT*PI()/180)*COS(LAT*PI()/180))))
*180/PI() 

- Field Name – HEIGHT_KM 

   - Equation: 
=WIDTH_KM/(COS(LAT*PI()/180)*COS(SSCLAT*PI()/180)*COS((LON-
SSCLON)*PI()/180)+SIN(LAT*PI()/180)*SIN(SSCLAT*PI()/180)) 

- Field Name – HEIGHT_D 

   - Equation: =((HEIGHT_KM/1815)*180)/PI() 

- Field Name – HI_WI_RATIO 

   - Equation: =ADJ_WID_D/HEIGHT_D 

- Field Name – AZIMUTH_R 

   - Equation: =IF((LAT-SSCLAT)=0,0,PI()/2-(ATAN(((NEWLON-
NEWSSLON)/(LAT-SSCLAT))))) 

- Field Name – AZIMUTH_D 

   - Equation: =AZIMUTH_R*180/PI() 

  - Method: File -> Save 

 

 

 

 98



7. Import and Export the Table from Access 
 - Platform: Microsoft Access 

 - Method: File -> Open 

  - Files of Type – All Files (*.*) 

  - First Row Contains Column Headings – Check 

  - Method: File -> Export… 

  - Save as Type – dBASE IV (*.dbf) 

8. Open DrawPPREllipses.mxd  
 - Platform: ArcGIS 9.1 

 - Method: File -> Open 

9. Import PPR Table & Global Mosaic 

 - Platform: ArcGIS 9.1 

 - Method: File -> Add Data… 

10. Add PPR Table as Points 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Add X/Y Data… 

  - Choose a Table – Current PPR Data Table 

  - X Field – NEGLON 

  - Y Field - LAT 

11. Save PPR Point Events as a Shapefile 
 - Platform: ArcGIS 9.1 

- Method: Right-Click Events File in Table of Contents -> Data -> Export Data… 

 - Use the same coordinate system as – the data frame - Checked 

12. Open VBA Script 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Macros -> Visual Basic Editor 

  - Select PPR2XIXEllipses - Adjust data path and filenames  

NOTE!! – If the file that is going to be created already exists in the selected directory, the 
program will not execute. 

NOTE!! – The Name of the Point shapefile to be used for the script must exactly match 
the listed shapefile name in the script or the program will not execute. 
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13. Run PPR2XIXEllipses Module 
 - Platform: ArcGIS 9.1 

 - Method: Tools -> Macros -> Macros -> PPR2XIXEllipses 

14. Join the Ellipse Shapefile Table to the Point Shapefile Table 
 - Platform: ArcGIS 9.1 

 - Method: Right-Click Ellipse File in Table of Contents -> Joins and Relates -> Join… 

  - 2. Choose the table to join – Point Shapefile 

  - 1. Choose the field in this layer – FID 

 - 3. Choose the field in the table - FID 

15. Save Ellipse File as a Shapefile 
 - Platform: ArcGIS 9.1 

- Method: Right-Click Ellipse File in Table of Contents -> Data -> Export Data… 

 - Use the same coordinate system as – the data frame - Checked 
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Appendix E – Final Project Proposal
 
Executive Summary 
Constant volcanic activity accompanied by intense sulfurous plumes has made one of 
Jupiter’s moons, Io, one of the most observed celestial bodies in recent history.  The 
abundance of giant calderas, lava lakes, volcanoes, and vast lava flows have drawn as 
much attention to Io as not only the first active volcanoes discovered within the solar 
system, but the most geologically active object ever observed.  These dramatic features 
on Io combined with Jupiter’s storms and rings, inspired NASA to embark on the Galileo 
mission to exclusively study Jupiter and its four largest moons.  On the Galileo 
spacecraft, the three instruments that emerged to be the most useful were the solid state 
imaging device (SSI), the near infrared mapping spectrometer (NIMS), and the 
photopolarimeter radiometer (PPR).  These three instruments produced numerous 
stunning images during the Galileo mission, but unfortunately each instrument acquires 
data in a different format and resolution.  

To optimize research and productivity, the data needs to be compiled in a system that is 
easy for scientists to view and analyze specific research based questions.  With the 
assistance of Dr. Julie Rathbun, researcher Shane Barrett will co-register, compile, and 
inventory all of the existing data of the Amirani region into a stand alone, GIS application 
for other researchers to simultaneously project all of the data, and accurately analyze the 
features present there.  The majority of current research on Io involves studying the 
volcanic eruptions, and trying to develop a time frame or history of how the eruptions 
have occurred, including the subsequent lava flows.  Deriving temperatures from the 
spectral data can not only locate the current lava flows, but can give researchers an 
indication of how an eruption has occurred, and how each flow has progressed within a 
defined time frame.  Most of the actual geologic and morphologic analysis will be 
performed by Dr. Julie Rathbun who has participated in numerous research projects 
regarding Io for the last 6 years, and has co-authored eleven published scientific papers 
regarding the Galilean moon.  The initial compilation of data and construction of the 
application will be facilitated by the various imagery analysis and geographic information 
science experiences Shane Barrett gained while obtaining his undergraduate degree. 

Solution Overview 
Initially, a remote sensing software package will be employed to import, and mosaic the 
imagery data obtained from the Galileo spacecraft, specifically the SSI and NIMS 
datasets. Due to the limited coverage and inconsistency of acquisition times, the NIMS 
dataset will also need to be registered to the SSI images to ensure the accuracy of further 
analysis.  Some analyses may also require the NIMS data to be classified in a specific 
manner, which would also need to be performed using a remote sensing software 
package.  PPR data is stored in the form of two ASCII text files and will need to first be 
converted into a form of surface temperature map, and registered to the other imagery 
data.  Once all of the Galileo data is correctly registered, it will need to be exported in a 
format that is readable by ESRI software.  Using ArcCatalog, a new geodatabse will be 
constructed to completely contain all of the data files produced by the remote sensing 
software.  The geodatabase will be using an Io projection defined under the solar system 
projections within the ArcGIS software.  Depending on the outcome of the NIMS and 
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PPR data, portions of the datasets may be converted or possibly digitized into usable 
shapefiles for improved user capabilities, performance, and detailed attribute data entry.    
These digitized data sets may include temperature readings from the NIMS and PPR data, 
or possibly surface features, such as volcanoes, calderas, or lava flows.   
Once the data has finally been compiled, the stand alone application will be constructed 
with further discussions with the client.  The application may possibly be constructed 
using ArcObjects, and Visual Basic programming to develop a basic viewer with general 
layer capabilities to view the existing datasets.  Another option of the stand alone 
application may be to construct an ArcIMS website for the researchers involved, to 
provide them with a little more functionality that the ArcObjects option.  Once the project 
is complete, researchers will be able to characterize features, and their distribution within 
the Amirani region of Io, which is essential for identifying the active volcanic and 
tectonic processes on the Galilean moon. 

Scope of Work 
Task 1 - Data Acquisition & Exploration 

The researchers will meet to discuss the overall implementation of the project, and 
potential methodologies to complete the task within the allotted time.  At this time, the 
researchers will also acquire the data collected form the Galileo spacecraft and begin to 
explore the data types, formats, acquisition times, and orbits.  The researchers will have 
to differentiate the separate data from each instrument and collaborate on methods to 
display and register each data type.  Some data types may need to be converted or 
modified to be displayed properly as well.  Projections, extents, and coordinate systems 
must also be either determined or defined during the exploration stage as well to ensure 
accuracy during the registration phase. 

Task 2 - Data Registration 

Each data set will be imported into a remote sensing software package to accurately 
display each image.  Every additional image will then need to be co-registered using a 
georeferencing method within the remote sensing software.  Registering will be done by 
data type first starting with the SSI data because it will be the most accurate of all three 
sets of data.  The NIMS and PPR data may then be registered to the SSI data using the 
same methods.   

Task 3 - Data Export & Import 

Once the all of the data is accurately registered, it will need to be exported from the 
remote sensing software in a format compatible with ESRI GIS software suites.  The 
format types available will include TIFF, IMAGE, and GRID files.  Once exported, the 
data will be imported into the GIS software and analyzed for accuracy. 

Task 4 - Geodatabase Design 

Once all of the data is imported into the GIS, a geodatabase will be created and designed 
to properly inventory all of the data into a single package.  The structure will be a 
personal geodatabase containing 2 distinct raster datasets designated to each data type.  
These raster catalogs will have their spatial reference properties defined by the specific Io 
2000 projection defined within the projected coordinate systems within the ESRI 

 102



software.  All of the existing data will then be imported and mosaic into their specific 
raster catalogs. 

Task O - Surface Feature Data Creation (Optional) 

From the combined data sets, surface features will become more visible.  These surface 
features may be better represented as a point, line, or polygon file and could be digitized 
into their own file for ease of use and identification by the end user. 

Task 5 - Stand Alone Application Development 

All of the data needs to be simultaneously projected to the end user for analysis.  Since 
most of the end users will not be located at nearby facilities, an application needs to be 
developed so numerous interested researchers can access the data.  An independent 
viewer may be constructed using ArcObjects, and Visual Basic programming to develop 
a basic viewer with general layer capabilities to view the existing datasets.  Another 
option of the stand alone application may be to construct an ArcIMS website for the 
researchers involved, to provide them with a little more functionality that the ArcObjects 
option.  The choice between the two formats will be determined after the all of the image 
processing ahs been completed.  The overall size of the data may not be small enough to 
compile onto a single CD that could be distributed to the users, so a website would be the 
most applicable option.  If the data isn’t very large, a small, basic GIS viewer with simple 
functionality will be constructed, compiled with the data, and sent to the user 

Flow Process Diagram 

 
 

Deliverables 
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• Georeferenced image data (Task 2) 
• Georeferenced Ellipsoid PPR data (Task 2) 
• Geodatabase containing all georeferenced data (Task 4) 
• Finished MIP Paper documenting the entire project (Task 5) 
• Georeferenced surface feature data (Task O) 
• Stand Alone Application/ Website containing all georeferenced data (Task 5) 
• Data CD containing all original and processed data (Task 5) 
• Final hard & digital maps for display in documentation and for client (Task 5) 
• Basic training for direct contact users (Task 5) 
• Final presentation of entire project for advisors, clients, and public (Task 5) 
• Basic application/website help documentation (Optional Task 5) 

Assumptions 

• All data from the client was collected with a recorded location 
• Client will give clear and concise direction of what the final product will 

entail 
• Client will provide support regarding the data 
• ENVI software will be available 
• Clients and other users hardware and software is capable viewing stand alone 

application or website 
• Future releases of GIS software will be capable of reading and displaying final 

geodatabase and its contents 
• The final project will be useful to the client and other researchers 
• The provided data is authentic and an accurate representation of the study area 

Schedule 
The schedule has been design in such a way that generously allots time to each task 
required to finish the project.  These timelines are more or less deadlines for each task, 
not excepted completion dates.  Assuming the project flows as planned; the final 
presentations and documentations will be presented sometime in November. 
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Appendix F – Project Design Specification 
Executive Summary
Constant volcanic activity accompanied by intense sulfurous plumes has made one of 
Jupiter’s moons, Io, one of the most observed celestial bodies in recent history.  The 
abundance of giant calderas, lava lakes, volcanoes, and vast lava flows have drawn as 
much attention to Io as not only the first active volcanoes discovered within the solar 
system, but the most geologically active object ever observed.  These dramatic features 
on Io combined with Jupiter’s storms and rings, inspired NASA to embark on the Galileo 
mission to exclusively study Jupiter and its four largest moons.  On the Galileo 
spacecraft, the three instruments that emerged to be the most useful were the solid state 
imaging device (SSI), the near infrared mapping spectrometer (NIMS), and the 
photopolarimeter radiometer (PPR).  These three instruments produced numerous 
stunning images during the Galileo mission, but unfortunately each instrument acquires 
data in a different format and resolution.  

 To optimize research and productivity, the data needs to be compiled in a system that is 
easy for scientists to view and analyze specific research based questions.  With the 
assistance of Dr. Julie Rathbun, researcher Shane Barrett will co-register, compile, and 
inventory all of the existing data of the Amirani region into a stand alone, GIS application 
for other researchers to simultaneously project all of the data, and accurately analyze the 
features present there.  The majority of current research on Io involves studying the 
volcanic eruptions, and trying to develop a time frame or history of how the eruptions 
have occurred, including the subsequent lava flows.  Deriving temperatures from the 
spectral data can not only locate the current lava flows, but can give researchers an 
indication of how an eruption has occurred, and how each flow has progressed within a 
defined time frame.  Most of the actual geologic and morphologic analysis will be 
performed by Dr. Julie Rathbun who has participated in numerous research projects 
regarding Io for the last 6 years, and has co-authored eleven published scientific papers 
regarding the Galilean moon.  The initial compilation of data and construction of the 
application will be facilitated by the various imagery analysis and geographic information 
science experiences Shane Barrett gained while obtaining his undergraduate degree. 

Functional Requirements Overview
o The system shall be provided through an ArcIMS website (ESRI Internet 

Service software) 
o The system shall be digitally stored on a server within Lewis Hall at the 

University of Redlands, California 
o The system shall be available to all computer systems with any operating 

system through a basic internet connection 
o The system shall have an appropriately customized interface that 

represents the study area 
o The system shall store all of the required SSI, NIMS and PPR data sets in 

a personal geodatabase 
o The system shall provide the user with basic Zoom in and out capabilities 

within the interface  
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o The system shall provide the user with basic Pan capabilities within the 
interface 

o The system shall provide the user the ability the change the display 
properties of the selected layers if necessary 

o The system shall provide the user the ability to save the current display as 
a .jpeg or .tiff image 

o The system shall provide the user the ability to turn data layers On or Off 
in the interface display 

System Description
Once the data has finally been compiled, the stand alone application will be constructed 
after further discussions with the client.  The vessel to which all Io researchers will be 
able to view the collection of data within the Amirani region will be a stand alone 
ArcIMS website to provide them with GIS functionality to view and manipulate the data.  
Once the project is complete, researchers will be able to characterize features, and their 
distribution within the Amirani region of Io, which is essential for identifying the active 
volcanic and tectonic processes on the Galilean moon. 

All of the data needs to be simultaneously projected to the end user for analysis.  Since 
most of the end users will not be located at nearby facilities, an application needs to be 
developed so numerous interested researchers can simultaneously access the data.   

An ArcIMS website would be ideal for this dilemma because it would be made available 
to any of these researchers through a basic internet connection.  All of the processing and 
data storage would be contained within the central server, making the user interface 
efficient enough to run on numerous types and degrees of personal computers.  The 
default user interface allows the designer to employ the use of basic GIS functionality 
such as zoom and pan.  Also, the customization ability of ArcIMS is relatively simple 
making a representative user interface easy to construct.  This interface can be simplified 
to accommodate users of the system that have minimal GIS exposure and experience.   

System Architecture
The architecture of the system is fairly simple.  The major component of analysis and 
research for Io is the SSI, NIMS, and PPR data.  All of these data sets were captured from 
the Galileo spacecraft from different sensors, at different times, and from different orbits 
of the moon.  All of these data sets must be processed and eventually transformed into 
useable datasets acceptable by the GIS.  These data sets will be compiled into a personal 
geodatabase for storage and advance capabilities.  The geodatabase must also be stored 
preferable on the same server as the ArcIMS site for simple access for the system.  The 
ArcIMS site must be able to read and display the components of the geodatabase so the 
researcher can view the data.  The researcher is potentially the most important part of the 
system.  The researcher is responsible for accessing the system and deriving useful 
information from the data to accurately identify the active volcanic and tectonic processes 
on the Galilean moon.  The researchers are the purpose of the system, so the system must 
be built to satisfy their requirements.   

The researcher will actively access the data through a custom designed interface.  The 
interface will be customized to represent an Io type theme as well as simplified for those 
researchers who have limited GIS experience.  Functionality included in the design 
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interface will include zoom, pan, layer properties, layer presence, and exporting as an 
image file.  If possible, the system will only have these specific buttons on the interface 
to avoid confusion by the researchers.  The zoom function will obviously allow the 
researcher to increase or decrease the scale at which they are viewing the data.  The pan 
function will allow the researcher to move the data displayed in any direction to capture 
other areas of the data without changing the scale at which the data is displayed.  The 
layer presence or function will allow the researcher to display or remove the selected data 
layer from the current display.  The layer properties function will allow the researcher to 
change the display properties of the selected layer such as color or transparency.  Finally, 
the save function will allow the researcher to export the current display extent as a image 
file such as a .jpeg or .tiff. 

 
 

System Environment
Hardware requirements for the researchers accessing the system are very broad.  The 
system shall be designed to be available to all operating systems on virtually any 
hardware configuration available.  However, a recommendation of a minimum 900 Mhz 
processor and 512 MB of RAM shall be made.  No peripheral software other than a basic 
internet viewer will be required for the researchers to view the system.  The user will be 
required to have an active internet connection available to them to contact the system’s 
web address.  For the design and maintenance of the system, ESRI’s ArcIMS software 
will be employed.  For some windows based systems two other sites may be constructed.  
A HTML site will be designed and in this case, some windows operating system users 
may be required to download and install a free version of ArcExplorer, also provided by 
ESRI.  In another potential variation, a Java site may also be constructed that would 
require the user to have the latest version of Java installed on their local machine.   

Software Design
The software employed for this system will be ESRI’s ArcIMS internet software.  This 
software will be utilized to design the website and eventual interface that the researcher 
can access to view the data from Io.   The finished website will be hosted on a central 
server in Lewis Hall at the University of Redlands in southern California.  The server 
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currently operates on a Windows Server 2003 operating system.  To configure ArcIMS 
website to the server, Apache and Tomcat configuration will be used.  

The only inputs of the system website will be the SSI, NIMS, and PPR data layers 
contained within a personal geodatabase.  From these inputs, the researchers will be able 
to identify surface processes and relationships from the simultaneously projected data.  
Unfortunately due to the simplicity of the system, there will be no data flow once the 
website is finalized.  The processes of the interface will include basic functionality 
provided in the default ArcIMS software package.  The functionality includes zoom, pan, 
layer properties, layer presence, and exporting as an image file.  These functions will be 
available through the interface as a labeled button.  The users can access the function by 
clicking on the button through the mouse cursor.  The click will either present a dialog 
box for the user to specify the parameters of the command, or change the cursor to 
another shape and allow the user to interactively utilize the tool in the viewer.   

Database Design

The SSI, NIMS, and PPR data will all be contained within a personal geodatabase with 
an appropriate naming scheme.  The SSI data will be contained within a managed raster 
catalog to organize the individual raster images in the same projection and coordinate 
system.  The images will also be compiled into one mosaic also contained within the 
catalog.   Similar to the SSI, the NIMS data will also be contained within a managed 
raster catalog.  The only real difference between the two data sets will be that the NIMS 
data will be contained in a multi spectral format, where the SSI is in a panchromatic 
image format.  The PPR may be the systems most simple data type but it requires the 
most complex storage system.  The PPR data will be stored within a feature dataset in 
two separate feature classes representing different orbits of the spacecraft.  In addition to 
the PPR data, another feature dataset may be created to contain any surface features that 
may be created during the analysis portion of the project.   
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User Interface Design

The basic Io interface will allow a researcher to add layers into the display frame from 
the Io Geodatabase and view them.  The user will have the ability to change their display 
properties, zoom, pan, and save the display in a jpeg or tiff format through command 
buttons beside the display frame.  The viewer will look quite basic, and consequently 
have basic functionality.   

 

 
http://gis.sarup.uwm.edu/gis4/changing_the_frameset_for_htmlvi.htm 

The presented image is a screenshot of a default viewer available through ArcIMS.  The 
interface for this project system will somewhat resemble this image, built with some 
subtle differences.  First, the interface will be customized to represent an Io type theme, 
such as maybe black, yellow, orange, and grey type color scheme.  Also the title will 
reflect the Io system.  Next, the functionality will be limited to only a few selected 
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commands.  Zoom, Pan, Save, Display Properties, and layer presence will be the only 
functions available to the user, and consequently those will be the only buttons available 
on the toolbar present on the right side of the viewer in the presented image.  Due to the 
lack of buttons, they too will be customized to show labels as well as pictures, and the 
size of the actual button will be increased for clarification. 
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Appendix G – Implementation Plan 
Executive Summary
Constant volcanic activity accompanied by intense sulfurous plumes has made one of 
Jupiter’s moons, Io, one of the most observed celestial bodies in recent history.  The 
abundance of giant calderas, lava lakes, volcanoes, and vast lava flows have drawn as 
much attention to Io as not only the first active volcanoes discovered within the solar 
system, but the most geologically active object ever observed.  These dramatic features 
on Io combined with Jupiter’s storms and rings, inspired NASA to embark on the Galileo 
mission to exclusively study Jupiter and its four largest moons.  On the Galileo 
spacecraft, the three instruments that emerged to be the most useful were the solid state 
imaging device (SSI), the near infrared mapping spectrometer (NIMS), and the 
photopolarimeter radiometer (PPR).  These three instruments produced numerous 
stunning images during the Galileo mission, but unfortunately each instrument acquires 
data in a different format and resolution.  

To optimize research and productivity, the data needs to be compiled in a system that is 
easy for scientists to view and analyze specific research based questions.  With the 
assistance of Dr. Julie Rathbun, researcher Shane Barrett will co-register, compile, and 
inventory all of the existing data of the Amirani region into a stand alone, GIS application 
for other researchers to simultaneously project all of the data, and accurately analyze the 
features present there.  The majority of current research on Io involves studying the 
volcanic eruptions, and trying to develop a time frame or history of how the eruptions 
have occurred, including the subsequent lava flows.  Deriving temperatures from the 
spectral data can not only locate the current lava flows, but can give researchers an 
indication of how an eruption has occurred, and how each flow has progressed within a 
defined time frame.  Most of the actual geologic and morphologic analysis will be 
performed by Dr. Julie Rathbun who has participated in numerous research projects 
regarding Io for the last 6 years, and has co-authored eleven published scientific papers 
regarding the Galilean moon.  The initial compilation of data and construction of the 
application will be facilitated by the various imagery analysis and geographic information 
science experiences Shane Barrett gained while obtaining his undergraduate degree. 

Updated Schedule 

ID Task Name Start Finish Duration
2006

Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov

1 60d3/31/20061/9/2006Data Acquisition & Exploration

2 108d8/30/20064/3/2006Data Registration

3 44d9/29/20068/1/2006Data Export & Import

4 43d4/28/20063/1/2006Geodatabase Design

5 21d9/29/20069/1/2006Surface Feature Data Creation

6 42d8/29/20067/3/2006Stand Alone Application Development

7 245d12/15/20061/9/2006Documentation
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Deliverables and Milestones 

• Georeferenced image data (Task 2) 
• Georeferenced Ellipsoid PPR data (Task 2) 
• Geodatabase containing all georeferenced data (Task 4) 
• Finished MIP Paper documenting the entire project (Task 5) 
• Georeferenced surface feature data (Task O) 
• Stand Alone Website containing all georeferenced data (Task 5) 
• Data CD containing all original and processed data (Task 5) 
• Final hard & digital maps for display in documentation and for client (Task 5) 
• Basic training for direct contact users (Task 5) 
• Final presentation of entire project for advisors, clients, and public (Task 5) 
• Basic website help documentation (Optional Task 5) 

Updated Risk Mitigation Plan 
Risk is a part of any project done, and therefore, also a part of this project.  The first and 
most critical risk has to be associated with the data.  Once again the data is in different 
formats, sizes, and scales and may possibly be the most difficult task of this project.  
Processing this data into one useable form will take a lot of time and effort, but is the 
most vital component of the project.  Without the association of the data types, the 
project will be an utter failure.  The critical risk of data registration has already been 
realized and is being dealt with as well by utilizing the raw data from the Galileo 
spacecraft rather then trying to manipulate existing preprocessed data.  There still may be 
risks involved with the registration itself that will have to be dealt with.  These risks 
should be avoidable by the familiarization of georeferencing and the associated data 
properties. 

A marginal risk associated with the data as the image processing software.  I have 
previous experience using ENVI software, but haven’t been exposed to it in well over a 
year.  Re-familiarizing myself with the software package may take a few days prior to the 
actual beginning of the data processing.  Similar to the registration, the ENVI software 
problem has been looked at, and I have spent some time familiarizing myself with the 
software a little more.  The last serious risk to the project may be the absence of the client 
and advisors during some of the processing phases of the project.  Their knowledge and 
insight to the project could be invaluable during these processes, and their absence may 
delay the certain aspects of the project until their return.  They are potentially the 
response to all of the other previously listed risks.   

Testing Approach 

The testing approach of the system in my MIP will be based on two simple factors; is the 
data displayed correctly, and can the users effectively view the data.  This testing will 
primarily be performed by my client, Julie Rathbun.  She will primarily be testing the 

 113



final data product to ensure that all of the data sets are simultaneously projected correctly 
over the same area of the Amirani region.  She will also be the primary inspector of the 
Website containing all of the data to ensure data quality and functionality of the website.  
My client will also be testing the website to ensure that new users will easily be able to 
use the site without any difficulty.  All of the primarily testing during construction of the 
website will be performed at the University of Redlands campus until the final 
completion when we will begin testing availability of the website on personal computers.  

Testing for the site is already underway for the duration of the construction and 
customization of the site, as well as the data quality.  The functionality of the website will 
be tested until the completion of the final project when final test will be performed by 
Julie and me.  The website is scheduled to be finished in mid-August and the data is 
scheduled to be finished by the end of September.   This essentially leaves me with two 
and a half months to ensure the website and data are ready for final testing and 
distribution.  The final testing will be complete when the two criteria stated earlier are 
fulfilled.  If the data is correctly projected of the Amirani Region in an ArcIMS website 
that is accessible to Io researchers that can easily and effectively view the data, the 
project testing will be complete. 

Test Methodology 

One method of testing the accuracy of the data projection is to compare the spatial 
coordinates of all three data sets.  I have recently received a script that can transform the 
original Isis cubes (images) from the Galileo spacecraft into an ArcGIS compatible 
image.  Since two of the data sets are image datasets, this script may be all of the testing 
needed to ensure the correct projection of the two datasets.  Also, the PPR data was 
capture to mimic the SSI data in the sense that some specific PPR shots were specifically 
recorded at the exact center of an SSI image capture.  These points could then be 
transformed to match the image data if needed.  To also capture a bit more accuracy from 
the data, the buffer created around the PPR data points will be derived from a calculation 
based on the position and distance of the spacecraft in relation to the moon.  This 
calculation will ensure the size (and hopefully shape) of each buffer will be as accurate as 
possible.  These three tests may provide the methods necessary to provide my client with 
enough confidence to begin performing research on the study area. 

Testing for the final website is seemingly less complicated.  Ongoing testing will be 
performed on the functionality of the website during the construction and customization 
of the site.  These tests will be concerned with the functions available to the user, and 
identifying any potential trouble areas.  The website must be extremely easy to use so 
these tests can be more opinion type views of the site from people other than myself.  
Julie is more knowledgeable about the users that will utilize this system and her opinions 
about the overall “feel” of the site will be invaluable to me.   Both of us will also test the 
availability of the site once it is finally published.  We will attempt to access the site from 
school and home from a few different platforms of personal computers as well as 
personal settings.  These tests will determine if the website is truly accessible to most of 
our users.   
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Test Scope 
The functionality of the system is relatively simple and the consequent testing will be 
simple as well.  The viewer functions of the site include various zoom and a single pan 
command.  These will obviously be tested by trying each of these buttons while the data 
is displayed.  Since these features are strictly “out of the box” functions, I expect no 
difficulty with them at all.  All of the various data set layers will be present in the table of 
contents within the viewer with a small check box to represent their presence in the 
viewer.  All layers will be tested by checking or un-checking the box and clicking the 
refresh map button.  The other function of exporting the viewer display as an image file is 
also another “out of the box” feature and is simply tested by performing the action.   

Test Acceptance 
As stated earlier, the client has two simple expectations of this project.  Once the data is 
displayed correctly in a simple viewer where users can easily and effectively view the 
data, the project testing will be complete.  Once the client examines the methods and 
accuracies of the data transformations as well as its final display, I am confident she will 
be pleased with the result.  As for the viewer, she must personally inspect the viewer and 
its simple functionality to ensure it allows her and others to perform the research she 
needs.  Once these criteria are met, the test will be successfully completed. 

Test Environment 
Site Requirements  

There are different requirements for hardware and software for the two separate criteria.  
For the data and website construction tests, all of the testing will be performed on my 
personal Sony Vaio laptop computer with a 2.0 GHz Intel processor, 1GB of RAM, and 
100 GB of storage space utilizing a Microsoft Windows XP operating system.  Software 
on this laptop includes Microsoft Office, Internet Explorer 7, ENVI 4.2, ArcIMS 9.1, and 
ArcGIS 9.1(ArcInfo License).  These will be the only software packages required for 
these tests.  For the final website testing, numerous different platforms will be utilized 
running numerous different operating systems, software packages, and internet browsers.  
The completed website will be hosted by a server at the University of Redlands 
exclusively dedicated to the deployment of ArcIMS websites by the Redlands Institute, 
and students of the MSGIS program.  This server will be the final container for the 
customized website, as well as the final data sets to view on the website.   

Staffing and Training 

No special staffing or training will be required for these tests 

Test Data 

No specific test data will be used for any testing either, only the original and transformed 
data will be utilized in these tests. 

Schedule 
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Testing Schedule

Item Expected Completion Date
Website August 31, 2006
Data September 30, 2006
Final October 15, 2006  

 

Adoption Plan 
The first and foremost challenge for the website application is to make the website easy 
to understand and use.  My client has stressed this to me on numerous occasions.  If the 
functions, data layers, or any other part of the website is difficult to understand, the 
website will need to be adjusted until my client is satisfied with its simplicity.  This will 
be avoided by keeping the website clear of any extra functions that the users don’t need, 
and labeling the existing functions and data layers very well so there would be no 
question whatsoever what the user would be viewing or applying.   

The ability of the website to e viewed on numerous types of hardware and software 
configurations will be another challenge that my client sees as crucial to the success of 
this website.  A lot of the Io researchers around the continent utilize Macintosh hardware 
and software.  It is critical that the website be compatible with these configurations or the 
convenience of the website could be at a loss.  By using HTML and Java applet 
compatible website designs, the website should be viewable though most Macintosh 
configurations, as well as a multitude of internet browsers capable of decoding HTML 
code, or by the utilization of individual Java applets specified for their operating system.   

The proper combination of the three data layers is essentially the basis for this entire 
project and must be successful for any of the other factors of this project to even exist.  
Through scripts, image processing, and geoprocessing, I assured my client that this 
project would be a success and I fully intend to keep that promise.   

Deployment Plan 
Deployment of the Io Viewer to the research community will be the first of its kind in 
this specific field of interest.  Not only will this be a prototype for the simultaneous 
projection of the three specific data types using any form of GIS, but it will also be the 
first time an interactive viewer was used to distribute the results over the internet.  The 
prototype will initially be deployed at the University of Redlands for the client, Julie 
Rathbun to explore and eventually approve for her uses among the Io research 
community. The website will be developed using ArcIMS 9.1 and hosted on an 
independent server dedicated to serving ArcIMS websites for the Redlands Institute and 
students of the MSGIS program.  All of the data will be compiled and stored on the 
server and distributed through the website using an ArcGIS 9.1 project file (.mxd).  The 
website will be created and deployed in an HTML format so most users will be able to 
view the site on their local computer utilizing a multitude of thin client internet browsers.   

For the deployment to be successfully completed, there are numerous other activities that 
must be completed, presented, and approved by the client.  The most time consuming 
element of the deployment process will be the complete documentation of the entire 
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project, containing all information from the exploratory beginnings through to the final 
delivered product.  This documentation will also contain a small user’s manual for the 
simplistic website, complete metadata for all of the data layers involved, and a number of 
prototype maps created using the processed data sets.  All of the documentation, data, and 
maps will also be provided on a CD for further distribution.  The final results of the Io 
project will be presented to a final committee for approval at the completion of the 
project.  This presentation could be thought of as a thesis defense or an educational 
presentation to any number of interested individuals.  A few presentations about the 
project will be given to a number of different audiences.  

The final delivery of the completed system to the client will be relatively simple.  Most of 
the system configuration and requirements will be dealt with during the testing of the 
system.  There will be no need for data conversion or any software installation because 
the final system will be provided exclusively through the internet.  The final component 
of the project deployment will be to provide the client with a brief introduction to the 
system and how to utilize the functionality of the website.  If the deployment of the new 
system needed to be labeled as anything, it would probably be referred to as a location 
conversion because it will only be deployed at one site as a prototype for other 
researchers to view.   

Training Plan 
 Training for the final product of the project will be exceedingly simple for the Io project.  
The objectives of the training will be focused on helping the client understand and have 
the ability to utilize the Io website and processed data.  Luckily, Julie has some 
experience with GIS and already understands the basic functionality of ESRI’s ArcGIS.  
These objectives will be easily reached by performing some one-on-one training with 
Julie to explore the datasets provided to her on CD, and through the website.  Through 
the data exploration training, the processes performed on the data will be discussed to the 
client so she fully understands how the final product was derived.  These final datasets 
will be explored using ArcGIS, and the provided website.  The website training should be 
exceedingly easily given Julie’s experience with GIS and its functionality.  Regardless, 
the training will include demonstrating the accessibility and functionality of the website. 

Operations Plan 
The nature of the final Io project viewer was to be a prototype for other researchers 
throughout the continent to view and evaluate the systems capability, to determine if GIS 
was a feasible platform for extended research with interstellar datasets.  Due to this fact, 
the expected life cycle of this website is relatively short.  The website will be hosted at 
the University of Redlands and up kept with minimal maintenance by the Redlands 
Institute staff.  The website will be one of many already hosted on the server by the 
institute.  
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Appendix H – Registering Mosaics VBA Code 
Option Explicit 
 
Sub CreateRegisteringPointsForMosaics() 
 
    'Declare variables 
    Dim sWSName As String 
    Dim sFCName As String 
     
    'Assign Values 
    sWSName = "C:\ShanesDocs\MySchool\MIP\ProcessedData\Registering" 
    sFCName = "MosaicPoints.shp" 
 
    'Set up a simple fields collections 
    Dim pFieldsEdit As IFieldsEdit 
    Set pFieldsEdit = New esriGeoDatabase.Fields 
     
    'Create a field 
    Dim pFieldEdit As IFieldEdit 
    Set pFieldEdit = New esriGeoDatabase.Field 
     
    'Shape field 
    pFieldEdit.Name = "Shape" 
    pFieldEdit.Type = esriFieldTypeGeometry 
     
    'Declare and Set Geometry Defenitions for new Shapefile 
    Dim pGeomDefEdit As IGeometryDefEdit 
    Set pGeomDefEdit = New GeometryDef 
    pGeomDefEdit.GeometryType = esriGeometryPoint 
    Set pGeomDefEdit.SpatialReference = New UnknownCoordinateSystem 
    Set pFieldEdit.GeometryDef = pGeomDefEdit 
     
    'Add Field 
    pFieldsEdit.AddField pFieldEdit 
     
    'Id field 
    Set pFieldEdit = New esriGeoDatabase.Field 
    pFieldEdit.Name = "ID" 
    pFieldEdit.Length = 10 
    pFieldEdit.Type = esriFieldTypeInteger 
     
    'Add Field 
    pFieldsEdit.AddField pFieldEdit 
     
    'X field 
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    Set pFieldEdit = New esriGeoDatabase.Field 
    pFieldEdit.Name = "X" 
    pFieldEdit.Length = 10 
    pFieldEdit.Type = esriFieldTypeDouble 
 
    'Add Field 
    pFieldsEdit.AddField pFieldEdit 
 
    'Y field 
    Set pFieldEdit = New esriGeoDatabase.Field 
    pFieldEdit.Name = "Y" 
    pFieldEdit.Length = 10 
    pFieldEdit.Type = esriFieldTypeDouble 
 
    'Add Field 
    pFieldsEdit.AddField pFieldEdit 
     
    'Open a Workspace 
    Dim pWF As IWorkspaceFactory 
    Set pWF = New ShapefileWorkspaceFactory 
     
    Dim pFWS As IFeatureWorkspace 
    Set pFWS = pWF.OpenFromFile(sWSName, 0) 
     
    'Create a FeatureClass 
    Dim pFC As IFeatureClass 
    Set pFC = pFWS.CreateFeatureClass(sFCName, pFieldsEdit, Nothing, _ 
                                        Nothing, esriFTSimple, "Shape", "") 
                                    
    'Create insert cursor 
    Dim pIFCursor As IFeatureCursor 
    Set pIFCursor = pFC.Insert(True) 
     
    'Create feature buffer 
    Dim pIFBuffer As IFeatureBuffer 
    Set pIFBuffer = pFC.CreateFeatureBuffer 
     
    'Create a point 
    Dim pPoint As IPoint 
    Set pPoint = New Point 
     
    '1st point 
    pPoint.PutCoords 0, -90 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 1 
    pIFBuffer.Value(3) = 0 

 119



    pIFBuffer.Value(4) = -90 
    pIFCursor.InsertFeature pIFBuffer 
     
    '2nd point 
    pPoint.PutCoords 0, 90 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 2 
    pIFBuffer.Value(3) = 0 
    pIFBuffer.Value(4) = 90 
    pIFCursor.InsertFeature pIFBuffer 
     
    '3rd point 
    pPoint.PutCoords 180, -90 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 3 
    pIFBuffer.Value(3) = 360 
    pIFBuffer.Value(4) = -90 
    pIFCursor.InsertFeature pIFBuffer 
     
    '4th point 
    pPoint.PutCoords 180, 90 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 4 
    pIFBuffer.Value(3) = 360 
    pIFBuffer.Value(4) = 90 
    pIFCursor.InsertFeature pIFBuffer 
     
    '5th point 
    pPoint.PutCoords -180, -90 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 5 
    pIFBuffer.Value(3) = 360 
    pIFBuffer.Value(4) = -90 
    pIFCursor.InsertFeature pIFBuffer 
     
    '6th point 
    pPoint.PutCoords -180, 90 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 6 
    pIFBuffer.Value(3) = 360 
    pIFBuffer.Value(4) = 90 
    pIFCursor.InsertFeature pIFBuffer 
     
    'Save it 
    pIFCursor.Flush 
     

 120



    'Set to Nothing 
    Set pFieldsEdit = Nothing 
    Set pFieldEdit = Nothing 
    Set pGeomDefEdit = Nothing 
    Set pIFBuffer = Nothing 
    Set pIFCursor = Nothing 
     
    'Create a simple Marker simple 
    Dim pSMS As ISimpleMarkerSymbol 
    Set pSMS = New SimpleMarkerSymbol 
    pSMS.Style = esriSMSSquare 
 
    'Specify a color 
    Dim pColor As IRgbColor 
    Set pColor = New RgbColor 
    pColor.RGB = RGB(0, 255, 0) 
    pSMS.Color = pColor 
 
    'Create a simple renderer 
    Dim pSimpleRenderer As ISimpleRenderer 
    Set pSimpleRenderer = New SimpleRenderer 
    Set pSimpleRenderer.Symbol = pSMS 
 
    'Get Document 
    Dim pMxDoc As IMxDocument 
    Set pMxDoc = ThisDocument 
 
    'Get Map 
    Dim pMap As IMap 
    Set pMap = pMxDoc.FocusMap 
     
    'Create a FeatureLayer and set the FeatureClass 
    Dim pFL As IFeatureLayer 
    Set pFL = New FeatureLayer 
    Set pFL.FeatureClass = pFC 
 
    'Declare Variables 
    Dim pLayer As ILayer 
    Set pLayer = pFL 
    pLayer.Name = sFCName 
    pLayer.ShowTips = True 
     
    'Adds Layer 
    pMap.AddLayer pFL 
     
    'Get 1st Layer and assign renderer 
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    Dim pGFLayer As IGeoFeatureLayer 
    Set pGFLayer = pMap.Layer(0) 
    Set pGFLayer.Renderer = pSimpleRenderer 
 
    'Update ToC and refresh content 
    pMxDoc.UpdateContents 
     
    'Declare Active Vew and Refresh Map 
    Dim pAV As IActiveView 
    Set pAV = pMxDoc.ActivatedView 
    pAV.Refresh 
     
End Sub 
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Appendix I – Registering SSI Code changes to Appendix H 
 
This is the unique name of the sub-routine so a user can identify it  
Sub CreateRegisteringPointsForSSI() 
 
This is the name of the point shapefile that the program will create 
sFCName = "SSIPoints.shp" 
 
These are the individual points to be created by the program 
    '1st point 
    pPoint.PutCoords -140, -10 
    Set pIFBuffer.Shape = pPoint 
This is the point number 
    pIFBuffer.Value(2) = 1 
This is the point longitude 
    pIFBuffer.Value(3) = 220 
This is the point latitude 
    pIFBuffer.Value(4) = -10 
    pIFCursor.InsertFeature pIFBuffer 
     
    '2nd point 
    pPoint.PutCoords -140, 40 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 2 
    pIFBuffer.Value(3) = 220 
    pIFBuffer.Value(4) = 40 
    pIFCursor.InsertFeature pIFBuffer 
     
    '3rd point 
    pPoint.PutCoords -60, -10 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 3 
    pIFBuffer.Value(3) = 300 
    pIFBuffer.Value(4) = -10 
    pIFCursor.InsertFeature pIFBuffer 
     
    '4th point 
    pPoint.PutCoords -60, 40 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 4 
    pIFBuffer.Value(3) = 300 
    pIFBuffer.Value(4) = 40 
    pIFCursor.InsertFeature pIFBuffer 
 
This is the color that the points will appear in ArcMap 
pColor.RGB = RGB(255, 0, 0) 
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Appendix J – Registering NIMS 24 Code changes to Appendix H 
 
Sub CreateRegisteringPointsForNIMS24() 
 
sFCName = "NIMS24Points.shp" 
 
    '1st point 
    pPoint.PutCoords -110, 17 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 1 
    pIFBuffer.Value(3) = 250 
    pIFBuffer.Value(4) = 17 
    pIFCursor.InsertFeature pIFBuffer 
     
    '2nd point 
    pPoint.PutCoords -110, 27.6 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 2 
    pIFBuffer.Value(3) = 250 
    pIFBuffer.Value(4) = 27.6 
    pIFCursor.InsertFeature pIFBuffer 
     
    '3rd point 
    pPoint.PutCoords -119.4, 17 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 3 
    pIFBuffer.Value(3) = 240.6 
    pIFBuffer.Value(4) = 17 
    pIFCursor.InsertFeature pIFBuffer 
     
    '4th point 
    pPoint.PutCoords -119.4, 27.6 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 4 
    pIFBuffer.Value(3) = 240.6 
    pIFBuffer.Value(4) = 27.6 
    pIFCursor.InsertFeature pIFBuffer 
 
pColor.RGB = RGB(0, 0, 255) 
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Appendix K – Registering NIMS 27 Code changes to Appendix H 
 
Sub CreateRegisteringPointsForNIMS27() 
 
sFCName = "NIMS27Points.shp" 
 
    '1st point 
    pPoint.PutCoords -106, 10 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 1 
    pIFBuffer.Value(3) = 254 
    pIFBuffer.Value(4) = 10 
    pIFCursor.InsertFeature pIFBuffer 
     
    '2nd point 
    pPoint.PutCoords -106, 37 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 2 
    pIFBuffer.Value(3) = 254 
    pIFBuffer.Value(4) = 37 
    pIFCursor.InsertFeature pIFBuffer 
     
    '3rd point 
    pPoint.PutCoords -123, 10 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 3 
    pIFBuffer.Value(3) = 237 
    pIFBuffer.Value(4) = 10 
    pIFCursor.InsertFeature pIFBuffer 
     
    '4th point 
    pPoint.PutCoords -123, 37 
    Set pIFBuffer.Shape = pPoint 
    pIFBuffer.Value(2) = 4 
    pIFBuffer.Value(3) = 237 
    pIFBuffer.Value(4) = 37 
    pIFCursor.InsertFeature pIFBuffer 
 
pColor.RGB = RGB(0, 255, 255) 
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Appendix L – Drawing PPR 24 IN Ellipses VBA Code 
 
Option Explicit 
 
Sub CreateEllipseShapefile24IN() 
 
'----------------------------------------------------------------------------- 
'Add PPR Shapefile 
'----------------------------------------------------------------------------- 
 
    'Declare variables 
    Dim sWSName As String 
    sWSName = "C:\ShanesDocs\MySchool\MIP\ProcessedData\PPR\Processing" 
    Dim sFCName As String 
    sFCName = "24INPPR.shp" 
     
    'Opening a Workspace 
    Dim pWF As IWorkspaceFactory 
    Set pWF = New ShapefileWorkspaceFactory 
     
    Dim pFWS As IFeatureWorkspace 
    Set pFWS = pWF.OpenFromFile(sWSName, 0) 
     
    'Open a FeatureClass 
    Dim pFC As IFeatureClass 
    Set pFC = pFWS.OpenFeatureClass(sFCName) 
     
    'Create a FeatureLayer and set the FeatureClass 
    Dim pFL As IFeatureLayer 
    Set pFL = New FeatureLayer 
    Set pFL.FeatureClass = pFC 
     
    'Create a Layer and set as FeatureClass 
    Dim pLayer As ILayer 
    Set pLayer = pFL 
    pLayer.Name = "24INPPR.shp" 
    pLayer.ShowTips = True 
     
    'Add layer in the Map 
    Dim pMxDoc As IMxDocument 
    Set pMxDoc = ThisDocument 
     
    'Declare Map and set to current Map Document 
    Dim pMap As IMap 
    Set pMap = pMxDoc.FocusMap 
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    'Add FeatureClassLayer to Map 
    pMap.AddLayer pFL 
     
    'Update ToC and refresh content 
    pMxDoc.UpdateContents 
     
    'Declare Active View and Refresh it 
    Dim pAV As IActiveView 
    Set pAV = pMxDoc.ActivatedView 
    pAV.Refresh 
 
'----------------------------------------------------------------------------- 
'Create Ellipse File 
'----------------------------------------------------------------------------- 
 
    'Declare Variable 
    Dim sNFCName As String 
    sNFCName = "24INEllipses.shp" 
 
    'Set up a simple fields collections 
    Dim pFieldsEdit As IFieldsEdit 
    Set pFieldsEdit = New esriGeoDatabase.Fields 
     
    'Create a field 
    Dim pFieldEdit As IFieldEdit 
    Set pFieldEdit = New esriGeoDatabase.Field 
     
    'Shape field 
    pFieldEdit.Name = "Shape" 
    pFieldEdit.Type = esriFieldTypeGeometry 
     
    'Declare and Set Geometry Defenitions for new Shapefile 
    Dim pGeomDefEdit As IGeometryDefEdit 
    Set pGeomDefEdit = New GeometryDef 
    pGeomDefEdit.GeometryType = esriGeometryPolygon 
    Set pGeomDefEdit.SpatialReference = New UnknownCoordinateSystem 
 
    'Set Field Collections to Geometry Defenitions 
    Set pFieldEdit.GeometryDef = pGeomDefEdit 
     
    'Adds Geometry Definitions fields 
    pFieldsEdit.AddField pFieldEdit 
     
    'Id field 
    Set pFieldEdit = New esriGeoDatabase.Field 
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    pFieldEdit.Name = "ID" 
    pFieldEdit.Length = 5 
    pFieldEdit.Type = esriFieldTypeInteger 
     
    'Adds Id filed 
    pFieldsEdit.AddField pFieldEdit 
     
    'Create a FeatureClass 
    Dim pNFC As IFeatureClass 
    Set pNFC = pFWS.CreateFeatureClass(sNFCName, pFieldsEdit, Nothing, _ 
                                        Nothing, esriFTSimple, "Shape", "") 
     
    'Declare and set table to FeatureClass 
    Dim theTable As ITable 
    Set theTable = pFC 
     
    'Declares an index for the FID field 
    Dim indFldIndex As Long 
    indFldIndex = theTable.FindField("FID") 
 
    'Declares an index for the HEIGHT_D field 
    Dim indHeight As Long 
    indHeight = theTable.FindField("HEIGHT_D") 
 
    'Declares an index for the ADJ_WID_D field 
    Dim indWidth As Long 
    indWidth = theTable.FindField("ADJ_WID_D") 
 
    'Declare an index for the HI_WI_RATIO field 
    Dim indRatio As Long 
    indRatio = theTable.FindField("HI_WI_RATI") 
     
    'Declare an index for the AZIMUTH_R field 
    Dim indAngle As Long 
    indAngle = theTable.FindField("AZIMUTH_R") 
 
    'Declares and sets a cursor to the first record 
    Dim pCursor As IFeatureCursor 
    Set pCursor = pFC.Search(Nothing, True) 
     
    'Declare and sets a row to the cursor 
    Dim theRow As IRow 
    Set theRow = pCursor.NextFeature 
     
    'Declares and sets the feature to the cursor at the row 
    Dim pFeature As IFeature 
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    Set pFeature = theRow 
        
    'Loops while the row has values in it 
    Do While Not theRow Is Nothing 
 
         'Declare and sets variables to the corresponding value in the table 
         Dim intI As Integer 
         intI = theRow.Value(indFldIndex) 
         Dim dblWidth As Double 
         dblWidth = theRow.Value(indWidth) 
         Dim dblHeight As Double 
         dblHeight = theRow.Value(indHeight) 
         Dim dblRatio As Double 
         dblRatio = theRow.Value(indRatio) 
         Dim dblAngle As Double 
         dblAngle = theRow.Value(indAngle) 
 
         'Declare Ellipse Variables 
         Dim pPolygon As esriGeometry.IPolygon 
         Dim pConstructEllipticArc As esriGeometry.IConstructEllipticArc 
         Dim pEllipticArc As esriGeometry.IEllipticArc 
         Dim pSeg As esriGeometry.ISegment 
         Dim pSegcoll As esriGeometry.ISegmentCollection 
         Dim pRing As esriGeometry.IRing 
         Dim pGeomColl As esriGeometry.IGeometryCollection 
         Dim pEnv As esriGeometry.IEnvelope 
         Dim pSR As esriGeometry.ISpatialReference 
         Set pSR = Nothing 
                   
         'Declare and set point feature to current feature 
         Dim pPoint As IPoint 
         Set pPoint = pFeature.Shape 
          
         'Determine extent of ellipse 
         Set pEnv = pPoint.Envelope 
         
         'Set Envelope spaital reference to the current map's 
         Set pEnv.SpatialReference = pMap.SpatialReference 
                   
         'Create Ellipse Elements 
         Set pEllipticArc = New esriGeometry.EllipticArc 
         Set pEllipticArc.SpatialReference = pSR 
         Set pConstructEllipticArc = pEllipticArc 
          
         'Draw ellipse from center point, from angle, central angle, rotation angle, semi 
major axis, minor Major Ratio 
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         pEllipticArc.PutCoordsByAngle False, pPoint, 0, 2 * 3.14159265358979, dblAngle, 
dblHeight, dblRatio 
                   
         'Draw Ellipse 
         Set pSeg = pEllipticArc 
         Set pSegcoll = New esriGeometry.Ring 
         pSegcoll.AddSegment pSeg 
         Set pRing = pSegcoll 
         Set pPolygon = New esriGeometry.Polygon 
         Set pPolygon.SpatialReference = pSR 
         Set pGeomColl = pPolygon 
         pGeomColl.AddGeometry pRing 
          
         'Create insert cursor 
         Dim pIFCursor As IFeatureCursor 
         Set pIFCursor = pNFC.Insert(True) 
     
         'Create feature buffer 
         Dim pIFBuffer As IFeatureBuffer 
         Set pIFBuffer = pNFC.CreateFeatureBuffer 
         Set pIFBuffer.Shape = pPolygon 
         pIFBuffer.Value(2) = intI 
         pIFCursor.InsertFeature pIFBuffer 
                    
         'Set Envelope to Nothing 
         Set pEnv = Nothing 
          
         'Save it 
         pIFCursor.Flush 
          
         'Set to Nothing 
         Set pFieldsEdit = Nothing 
         Set pFieldEdit = Nothing 
         Set pGeomDefEdit = Nothing 
         Set pIFBuffer = Nothing 
         Set pIFCursor = Nothing 
     
         'Set the cursor to the next feature 
         Set theRow = pCursor.NextFeature 
          
    Loop 
     
    'Create a FeatureLayer and set the FeatureClass 
    Dim pNFL As IFeatureLayer 
    Set pNFL = New FeatureLayer 
    Set pNFL.FeatureClass = pNFC 
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    'Declare Variables 
    Dim pNLayer As ILayer 
    Set pNLayer = pNFL 
    pNLayer.Name = sNFCName 
    pNLayer.ShowTips = True 
     
    'Adds Layer 
    pMap.AddLayer pNFL 
     
    'Get 1st Layer and assign renderer 
    Dim pNGFLayer As IGeoFeatureLayer 
    Set pNGFLayer = pMap.Layer(0) 
 
    'Update ToC 
    pMxDoc.UpdateContents 
     
    'Refresh Content 
    pAV.Refresh 
     
End Sub 
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Appendix M – Drawing PPR 24 IS and 27 IN Ellipses Code changes to 
Appendix L 
 
This is the unique name of the sub-routine so a user can identify it  
Sub CreateEllipseShapefile24IS() 
 
This is the name of the PPR point shapefile being imported to create the ellipses 
sFCName = "24ISPPR.shp” 
 
This is the display name of the point shapefile in the Table of Contents within ArcGIS 
pLayer.Name = "24ISPPR.shp” 
 
This is the name of the Ellipse shapefile that the program will create 
sNFCName = "24ISEllipses.shp” 
 
 
Sub CreateEllipseShapefile27IN() 
 
sFCName = "27INPPR.shp” 
 
pLayer.Name = "27INPPR.shp” 
 
sNFCName = "27INEllipses.shp” 
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Appendix N – Sample Metadata for PPR data utilizing PPR_24IN 
 
PPR_24IN 
 
Metadata also available as  
 
Metadata: 

• Identification_Information  
• Data_Quality_Information  
• Spatial_Data_Organization_Information  
• Spatial_Reference_Information  
• Entity_and_Attribute_Information  
• Distribution_Information  
• Metadata_Reference_Information  

 
Identification_Information:  

Citation:  
Citation_Information:  
Originator:  
Files: 24inamskgi01.geo & 24inamskgi01.rad, Contributors: Galileo Spacecraft, 
NASA, JPL  
Publication_Date: 2006  
Title: PPR_24IN  
Geospatial_Data_Presentation_Form: vector digital data  
Online_Linkage:  
\\SHANE_BARRETT\C$\ShanesDocs\MySchool\MIP\ProcessedData\FinalData\
Geodatabase\Io.mdb  
Description:  
Abstract:  
Ellipses of the PPR data captured during the 24th orbit of the Galileo Spacecraft  
Purpose:  
PPR data captured surface temperatures of Io between 60 and 600 degrees Kelvin  
Time_Period_of_Content:  
Time_Period_Information:  
Single_Date/Time:  
Calendar_Date: 1999  
Currentness_Reference: ground condition  
Status:  
Progress: Complete  
Maintenance_and_Update_Frequency: As needed  
Spatial_Domain:  
Bounding_Coordinates:  
West_Bounding_Coordinate: -117.894770  
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East_Bounding_Coordinate: -112.042960  
North_Bounding_Coordinate: 25.641660  
South_Bounding_Coordinate: 21.566170  
Keywords:  
Theme:  
Theme_Keyword_Thesaurus: None  
Theme_Keyword: PPR, Polygons, Ellipses, Temperatures  
Place:  
Place_Keyword: Io  
Temporal:  
Temporal_Keyword: 1999  
Access_Constraints: None  
Use_Constraints: None  
Point_of_Contact:  
Contact_Information:  
Contact_Person_Primary:  
Contact_Person: Dr. Julie Rathbun  
Contact_Organization: University of Redlands  
Contact_Position: Physics Professor  
Contact_Address:  
Address_Type: mailing and physical address  
Address: 1200 East Colton Avenue  
Address: P.O. Box 3080  
City: Redlands  
State_or_Province: California  
Postal_Code: 92373-0999  
Contact_Voice_Telephone: (909) 793 2121  
Contact_Electronic_Mail_Address: Julie_Rathbun@redlands.edu  
Data_Set_Credit: Galileo Spacecraft, NASA, JPL  
Native_Data_Set_Environment:  
Microsoft Windows XP Version 5.1 (Build 2600) Service Pack 2; ESRI 
ArcCatalog 9.1.0.780  

 
Data_Quality_Information:  

Lineage:  
Process_Step:  
Process_Description:  
Executed custom script that draws an ellipse for each record within the point 
shapefile based on their unique location, short axis, long axis and azimuth and 
saves them as a polygon shapefile  
Process_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
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Process_Step:  
Process_Description:  
Table was joined to the corresponding point shapefile table and exported as a final 
polygon shapefile  
Process_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Process_Step:  
Process_Description: Metadata imported.  
Source_Used_Citation_Abbreviation: 
C:\DOCUME~1\SHANE_~1\LOCALS~1\Temp\xml30.tmp  

 
Spatial_Data_Organization_Information:  

Direct_Spatial_Reference_Method: Vector  
Point_and_Vector_Object_Information:  
SDTS_Terms_Description:  
SDTS_Point_and_Vector_Object_Type: G-polygon  
Point_and_Vector_Object_Count: 332  

 
Spatial_Reference_Information:  

Horizontal_Coordinate_System_Definition:  
Geographic:  
Latitude_Resolution: 0.000010  
Longitude_Resolution: 0.000010  
Geographic_Coordinate_Units: Decimal degrees  
Geodetic_Model:  
Horizontal_Datum_Name: D_Io_2000  
Ellipsoid_Name: Io_2000_IAU_IAG  
Semi-major_Axis: 1821460.000000  
Denominator_of_Flattening_Ratio: infinity  
Vertical_Coordinate_System_Definition:  
Altitude_System_Definition:  
Altitude_Resolution: 0.000010  
Altitude_Encoding_Method:  
Explicit elevation coordinate included with horizontal coordinates  

 
Entity_and_Attribute_Information:  

Detailed_Description:  
Entity_Type:  
Entity_Type_Label: PPR_24IN  
Attribute:  
Attribute_Label: OBJECTID  
Attribute_Definition: Internal feature number.  
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Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Shape  
Attribute_Definition: Feature geometry.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain: Coordinates defining the features.  
Attribute:  
Attribute_Label: ID  
Attribute_Definition: Identifying Number  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: FID_1  
Attribute_Definition: Identifying Number  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: ADJUSTED_S  
Attribute_Definition: Time of sample, taken from corresponding ASCII data file 
(.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: ADJUSTED_R  
Attribute_Definition:  
Spacecraft clock RIM count, which increments by one (1) every 60 and 2/3 
seconds, or 91 minor frames (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: LAT  
Attribute_Definition: Latitude of FOV intercept point (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: LON  
Attribute_Definition: Longitude of FOV intercept point (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: NEGLON  
Attribute_Definition:  
LON adjusted to confrom to coordinate systems with negative values west of the 
central meridian (Equation=LON*(-1))  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: NEWLON  
Attribute_Definition:  
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LON adjusted to confrom to coordinate systems between 0 and 360 degrees 
(Equation=360-LON)  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: RA  
Attribute_Definition: Right ascension of scan platform boresight (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: DEC_  
Attribute_Definition: Declination of scan platform boresight (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: INC  
Attribute_Definition: Solar incidence angle (sun-intercept-zenith) at the FOV 
(.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: EMI  
Attribute_Definition: Emission angle (spacecraft-intercept-zenith) at the FOV 
(.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: PHS  
Attribute_Definition: Phase angle (sun-intercept-spacecraft) at the FOV (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: DLIMB  
Attribute_Definition: Angle between FOV center and nearest point on body limb 
(.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: SIPDIS  
Attribute_Definition: Distance from spacecraft to FOV intercept point, km (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: TRANGE  
Attribute_Definition: Distance from spacecraft to target body center, km (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: SSCLON  
Attribute_Definition: Longitude of sub-spacecraft point (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: NEWSSCLON  
Attribute_Definition:  
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SSCLON adjusted to confrom to coordinate systems between 0 and 360 degrees 
(Equation=360-SSCLON)  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: SSCLAT  
Attribute_Definition: Latitude of sub-spacecraft point (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: SSOLON  
Attribute_Definition: Longitude of sub-solar point (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: SSOLAT  
Attribute_Definition: Latitude of sub-solar point (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: CONE  
Attribute_Definition: Scan platform cone angle (0-180) (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: CLOCK  
Attribute_Definition: Scan platform clock angle (0-360) (.geo)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: RIM_MOD91  
Attribute_Definition:  
Spacecraft clock MOD91, or minor frame counter, adjusted to represent the time 
at which the PPR instrument acquired the data sample pair for this record (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: PF  
Attribute_Definition: Programmed filter/retarder wheel position (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: GAIN  
Attribute_Definition: Radiometry gain step (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: MED  
Attribute_Definition:  
PPR operation mode, 0 - Transition, 1 - Cycle, 2 - 
PP/PH(PhotoPolarimetry/Photometry), 3 - Photometry, 4 - Radiometry, 5 - 
Position Select (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: COPS  
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Attribute_Definition:  
C - calibration lamp flag, O - boom sequence operation flag, P - number of 
positions, S - number of samples (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: TEMP_RID  
Attribute_Definition:  
Temp - science temperature presented as a character integer, R - temperature 
range flag , ID - temperature ID (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: FRP  
Attribute_Definition: Filter Position (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: SDNA  
Attribute_Definition:  
Sample A Data - the first PP/PH science data sample of the simultaneously 
obtained pair corresponding to the orthogonal polarization components separated 
by the PPR Wollaston prism or a radiometry scene sample (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: SDNB  
Attribute_Definition:  
Sample B Data - second of the pair of PP/PH science data samples or a science 
temperature data sample if Sample A Data is radiometry data (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: RA1  
Attribute_Definition:  
Right ascension of the instrument boresight direction for the spacecraft scan 
platform (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: DEC1  
Attribute_Definition:  
Declination of the instrument boresight direction for the spacecraft scan platform 
(.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: RAD_DN_  
Attribute_Definition: Radiometry Data Number (.rad)  
Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: T_K_  
Attribute_Definition: Brightness Temperature recorded in Kelvin (.rad)  
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Attribute_Definition_Source: NASA  
Attribute:  
Attribute_Label: WIDTH_KM  
Attribute_Definition:  
Ellipse short axis in kilometers (Equation=SIPDIS*TAN((2.5/2)/1000))  
Attribute_Definition_Source: University of Redlands, Weisstein (1999) 
Attribute:  
Attribute_Label: HEIGHT_KM  
Attribute_Definition:  
Ellipse long axis in kilometers 
(Equation=WIDTH_KM/(COS(LAT*PI()/180)*COS(SSCLAT*PI()/180)*COS((
LON-SSCLON)*PI()/180)+SIN(LAT*PI()/180)*SIN(SSCLAT*PI()/180)))  
Attribute_Definition_Source: University of Redlands, Weisstein (1999)   
Attribute:  
Attribute_Label: WIDTH_D  
Attribute_Definition:  
Ellipse short axis in decimal degrees (Equation=((WIDTH_KM/1815)*180)/PI())  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: HEIGHT_D  
Attribute_Definition:  
Ellipse long axis in decimal degrees (Equation=((HEIGHT_KM/1815)*180)/PI())  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: ADJ_WID_D  
Attribute_Definition:  
Adjusted Ellipse short axis in Degrees 
(Equation=(ACOS((COS(WIDTH_D*PI()/180)-
SIN(LAT*PI()/180)*SIN(LAT*PI()/180))/(COS(LAT*PI()/180)*COS(LAT*PI()/
180))))*180/PI())  
Attribute_Definition_Source: University of Redlands, Weisstein (1999) 
Attribute:  
Attribute_Label: HI_WI_RATI  
Attribute_Definition:  
Ratio of Height (long axis) to Width (short axis) 
(Equation=ADJ_WID_D/HEIGHT_D)  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: AZIMUTH_R  
Attribute_Definition:  
Azimuth derived from coordinates of NEWSSCLON and SSCLAT to NEWLON 
and LAT in radians (Equation=IF((LAT-SSCLAT)=0,0,PI()/2-
(ATAN(((NEWLON-NEWSSLON)/(LAT-SSCLAT))))))  
Attribute_Definition_Source: University of Redlands, Wolf & Ghilani (2002)  
Attribute:  
Attribute_Label: AZIMUTH_D  

 140



Attribute_Definition:  
Azimuth derived from coordinates of NEWSSCLON and SSCLAT to NEWLON 
and LAT in degrees (Equation=AZIMUTH_R*180/PI())  
Attribute_Definition_Source: University of Redlands  
Attribute:  
Attribute_Label: Shape_Length  
Attribute_Definition: Length of feature in internal units.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain: Positive real numbers that are automatically generated.  
Attribute:  
Attribute_Label: Shape_Area  
Attribute_Definition: Area of feature in internal units squared.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain: Positive real numbers that are automatically generated.  
Attribute:  
Attribute_Label: T_K_Subclass  
Attribute_Definition: Subclass of T_K  
Attribute_Definition_Source: University of Redlands  

 
Distribution_Information:  

Resource_Description: Downloadable Data  
 

Metadata_Reference_Information:  
Metadata_Date: 20061208  
Metadata_Contact:  
Contact_Information:  
Contact_Person_Primary:  
Contact_Person: Shane Barrett  
Contact_Organization: University of Redlands  
Contact_Position: Master's Student  
Contact_Address:  
Address_Type: mailing and physical address  
Address: 1200 East Colton Avenue  
Address: P.O. Box 3080  
City: Redlands  
State_or_Province: California  
Postal_Code: 92373-0999  
Country: USA  
Contact_Voice_Telephone: (909) 522 4792  
Contact_Electronic_Mail_Address: Shane_Barrett@redlands.edu  
Metadata_Standard_Name: FGDC Content Standards for Digital Geospatial 
Metadata  
Metadata_Standard_Version: FGDC-STD-001-1998  
Metadata_Time_Convention: local time  

 141



Metadata_Extensions:  
Online_Linkage: <http://www.esri.com/metadata/esriprof80.html>  
Profile_Name: ESRI Metadata Profile  
Metadata_Extensions:  
Online_Linkage: <http://www.esri.com/metadata/esriprof80.html>  
Profile_Name: ESRI Metadata Profile  
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Appendix O – Sample Metadata for NIMS data utilizing NIMS_24 
 
NIMS_24 
 
Metadata also available as  

Metadata:  

• Identification_Information  
• Data_Quality_Information  
• Spatial_Data_Organization_Information  
• Spatial_Reference_Information  
• Entity_and_Attribute_Information  
• Distribution_Information  
• Metadata_Reference_Information  

 
Identification_Information:  

Citation:  
Citation_Information:  
Originator: File: 24inamskgi01, Contributors: Galileo Spacecraft, NASA, JPL  
Publication_Date: 1999  
Title: NIMS_24  
Geospatial_Data_Presentation_Form: remote-sensing image  
Online_Linkage:  
\\SHANE_BARRETT\C$\ShanesDocs\MySchool\MIP\ProcessedData\FinalData\
Geodatabase\Io.idb\c_32\r_1.img  
Description:  
Abstract:  
Multispectral image capturing infrared radiation captured during the 24th orbit of 
the Galileo Spacecraft  
Purpose: NIMS data captured high surface temperatures of Io  
Time_Period_of_Content:  
Time_Period_Information:  
Single_Date/Time:  
Calendar_Date: 1999  
Currentness_Reference: ground condition  
Status:  
Progress: Complete  
Maintenance_and_Update_Frequency: As needed  
Spatial_Domain:  
Bounding_Coordinates:  
West_Bounding_Coordinate: -119.400000  
East_Bounding_Coordinate: -110.000000  
North_Bounding_Coordinate: 27.600000  
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South_Bounding_Coordinate: 17.025000  
Keywords:  
Theme:  
Theme_Keyword_Thesaurus: None  
Theme_Keyword: Mulitspectral, Imagery, Temperatures  
Place:  
Place_Keyword: Io  
Temporal:  
Temporal_Keyword: 1999  
Access_Constraints: None  
Use_Constraints: None  
Point_of_Contact:  
Contact_Information:  
Contact_Person_Primary:  
Contact_Person: Dr. Julie Rathbun  
Contact_Organization: University of Redlands  
Contact_Position: Physics Professor  
Contact_Address:  
Address_Type: mailing and physical address  
Address: 1200 East Colton Avenue  
Address: P.O. Box 3080  
City: Redlands  
State_or_Province: California  
Postal_Code: 92373-0999  
Country: USA  
Contact_Voice_Telephone: (909) 793 2121  
Contact_Electronic_Mail_Address: Julie_Rathbun@redlands.edu  
Native_Data_Set_Environment:  
Microsoft Windows XP Version 5.1 (Build 2600) Service Pack 2; ESRI 
ArcCatalog 9.1.0.780  

 
Data_Quality_Information:  

Lineage:  
Process_Step:  
Process_Description: Imported from IDL variable using Amirani.pro program  
Process_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Process_Step:  
Process_Description: Exported as ERDAS IMAGINE image file  
Process_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
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Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Process_Step:  
Process_Description:  
Georeferenced images by registering corners to extent coordinates points 
produced by custom script  
Process_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  

 
Spatial_Data_Organization_Information:  

Direct_Spatial_Reference_Method: Raster  
Raster_Object_Information:  
Raster_Object_Type: Pixel  
Row_Count: 54  
Column_Count: 48  
Vertical_Count: 1  

 
Spatial_Reference_Information:  

Horizontal_Coordinate_System_Definition:  
Geographic:  
Geographic_Coordinate_Units: Decimal degrees  
Planar:  
Planar_Coordinate_Information:  
Planar_Coordinate_Encoding_Method: row and column  
Coordinate_Representation:  
Abscissa_Resolution: 0.195833  
Ordinate_Resolution: 0.195833  
Geodetic_Model:  
Horizontal_Datum_Name: D_Io_2000  
Ellipsoid_Name: Io_2000_IAU_IAG  
Semi-major_Axis: 1821460.000000  
Denominator_of_Flattening_Ratio: infinity  

 
Entity_and_Attribute_Information:  

Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_1  
Entity_Type_Definition: Wavelength: 0.587000 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
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Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_2  
Entity_Type_Definition: Wavelength: 0.725800 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_3  
Entity_Type_Definition: Wavelength: 1.03480 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_4  
Entity_Type_Definition: Wavelength: 1.31280 microns  
Entity_Type_Definition_Source: NASA, JPL  
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Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_5  
Entity_Type_Definition: Wavelength: 1.59280 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_6  
Entity_Type_Definition: Wavelength: 1.87370 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_7  
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Entity_Type_Definition: Wavelength: 2.43840 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_8  
Entity_Type_Definition: Wavelength: 2.71760 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_9  
Entity_Type_Definition: Wavelength: 3.00070 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
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Entity_Type:  
Entity_Type_Label: Band_10  
Entity_Type_Definition: Wavelength: 3.28310 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_11  
Entity_Type_Definition: Wavelength: 3.56590 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_12  
Entity_Type_Definition: Wavelength: 3.84890 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
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Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_13  
Entity_Type_Definition: Wavelength: 4.13260 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_14  
Entity_Type_Definition: Wavelength: 4.41450 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_15  
Entity_Type_Definition: Wavelength: 4.69670 microns  
Entity_Type_Definition_Source: NASA, JPL  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
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Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  

 
Distribution_Information:  

Resource_Description: Downloadable Data  
Standard_Order_Process:  
Digital_Form:  
Digital_Transfer_Information:  
Transfer_Size: 0.000  

 
Metadata_Reference_Information:  

Metadata_Date: 20061208  
Metadata_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Contact_Address:  
Address_Type:  
REQUIRED: The mailing and/or physical address for the organization or 
individual.  
City: REQUIRED: The city of the address.  
State_or_Province: REQUIRED: The state or province of the address.  
Postal_Code: REQUIRED: The ZIP or other postal code of the address.  
Contact_Voice_Telephone: (909) 522 4792  
Contact_Electronic_Mail_Address: Shane_Barrett@redlands.edu  
Metadata_Standard_Name: FGDC Content Standards for Digital Geospatial 
Metadata  
Metadata_Standard_Version: FGDC-STD-001-1998  
Metadata_Time_Convention: local time  
Metadata_Extensions:  
Online_Linkage: <http://www.esri.com/metadata/esriprof80.html>  
Profile_Name: ESRI Metadata Profile  
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Appendix P – SSI Metadata 
 
SSI 
 
Metadata also available as  
 
Metadata: 

• Identification_Information  
• Data_Quality_Information  
• Spatial_Data_Organization_Information  
• Spatial_Reference_Information  
• Entity_and_Attribute_Information  
• Distribution_Information  
• Metadata_Reference_Information  

 
Identification_Information:  

Citation:  
Citation_Information:  
Originator: File: I24AMSKGI01, Contributors: Galileo Spacecraft, NASA, JPL  
Publication_Date: 1999  
Title: SSI  
Geospatial_Data_Presentation_Form: remote-sensing image  
Online_Linkage:  
\\SHANE_BARRETT\C$\ShanesDocs\MySchool\MIP\ProcessedData\FinalData\
Geodatabase\Io.idb\c_45\r_1.img  
Description:  
Abstract:  
Captured high resolution (0.5 - 25 km) images of the surface of Io  
Purpose: Map and identify changes in the surfaces of Io  
Time_Period_of_Content:  
Time_Period_Information:  
Single_Date/Time:  
Calendar_Date: 1999  
Currentness_Reference: ground condition  
Status:  
Progress: Complete  
Maintenance_and_Update_Frequency: As needed  
Spatial_Domain:  
Bounding_Coordinates:  
West_Bounding_Coordinate: -142.402771  
East_Bounding_Coordinate: -67.862861  
North_Bounding_Coordinate: 41.388852  
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South_Bounding_Coordinate: -9.054890  
Keywords:  
Theme:  
Theme_Keyword_Thesaurus: None  
Theme_Keyword: SSI, image, surface, raster  
Place:  
Place_Keyword: Io  
Temporal:  
Temporal_Keyword: 1999  
Access_Constraints: None  
Use_Constraints: None  
Point_of_Contact:  
Contact_Information:  
Contact_Person_Primary:  
Contact_Person: Dr. Julie Rathbun  
Contact_Organization: University of Redlands  
Contact_Position: Physics Professor  
Contact_Address:  
Address_Type: mailing and physical address  
Address: 1200 East Colton Avenue  
Address: P.O. Box 3080  
City: Redlands  
State_or_Province: California  
Postal_Code: 92373-0999  
Country: USA  
Contact_Voice_Telephone: (909) 793 2121  
Contact_Electronic_Mail_Address: Julie_Rathbun@redlands.edu  
Native_Data_Set_Environment:  
Microsoft Windows XP Version 5.1 (Build 2600) Service Pack 2; ESRI 
ArcCatalog 9.1.0.780  

 
Data_Quality_Information:  

Lineage:  
Process_Step:  
Process_Description: Imported from IDL variable using Amirani.pro program  
Process_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Process_Step:  
Process_Description:  
Image scaled to an 8-bit image Equation: NewSSI = fix(((float(b1)-
min)/range)*255)  
Process_Contact:  
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Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Process_Step:  
Process_Description: Exported as TIFF file  
Process_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Process_Step:  
Process_Description: Georeferenced to Global BW_Mosaic using 50 control 
points  

 
Spatial_Data_Organization_Information:  

Direct_Spatial_Reference_Method: Raster  
Raster_Object_Information:  
Raster_Object_Type: Pixel  
Row_Count: 829  
Column_Count: 1225  
Vertical_Count: 1  

 
Spatial_Reference_Information:  

Horizontal_Coordinate_System_Definition:  
Geographic:  
Geographic_Coordinate_Units: Decimal degrees  
Planar:  
Planar_Coordinate_Information:  
Planar_Coordinate_Encoding_Method: row and column  
Coordinate_Representation:  
Abscissa_Resolution: 0.060849  
Ordinate_Resolution: 0.060849  
Geodetic_Model:  
Horizontal_Datum_Name: D_Io_2000  
Ellipsoid_Name: Io_2000_IAU_IAG  
Semi-major_Axis: 1821460.000000  
Denominator_of_Flattening_Ratio: infinity  

 
Entity_and_Attribute_Information:  

Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_1  
Attribute:  
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Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  

 
Distribution_Information:  

Resource_Description: Downloadable Data  
Standard_Order_Process:  
Digital_Form:  
Digital_Transfer_Information:  
Transfer_Size: 0.000  

 
Metadata_Reference_Information:  

Metadata_Date: 20061208  
Metadata_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Contact_Address:  
Address_Type: mailing and physical address  
Address: 1200 East Colton Avenue  
Address: P.O. Box 3080  
City: Redlands  
State_or_Province: California  
Postal_Code: 92373-0999  
Country: USA  
Contact_Voice_Telephone: (909) 522 4792  
Contact_Electronic_Mail_Address: Shane_Barrett@redlands.edu  
Metadata_Standard_Name: FGDC Content Standards for Digital Geospatial 
Metadata  
Metadata_Standard_Version: FGDC-STD-001-1998  
Metadata_Time_Convention: local time  
Metadata_Extensions:  
Online_Linkage: <http://www.esri.com/metadata/esriprof80.html>  
Profile_Name: ESRI Metadata Profile  
Metadata_Extensions:  
Online_Linkage: <http://www.esri.com/metadata/esriprof80.html>  
Profile_Name: ESRI Metadata Profile  
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Appendix Q – Sample Metadata for Mosaics data utilizing Color Mosaic 
 
Color_Mosaic 
 
Metadata also available as  
 
Metadata: 

• Identification_Information  
• Data_Quality_Information  
• Spatial_Data_Organization_Information  
• Spatial_Reference_Information  
• Entity_and_Attribute_Information  
• Distribution_Information  
• Metadata_Reference_Information  

 
Identification_Information:  

Citation:  
Citation_Information:  
Originator:  
File: GLL_color_Simp_Clon180_8bit.tif, Contributors: Voyager Spacecraft, 
Galileo Spacecraft, NASA, JPL, USGS  
Publication_Date: 2006  
Title: Color_Mosaic  
Geospatial_Data_Presentation_Form: remote-sensing image  
Online_Linkage:  
\\SHANE_BARRETT\C$\ShanesDocs\MySchool\MIP\ProcessedData\FinalData\
Geodatabase\Io.idb\c_43\r_1.img  
Description:  
Abstract: A color global mosaic of Io  
Purpose:  
Global mosaic provides a background on which other data can be displayed. Also 
used for identification and relation of features on the surface of Io.  
Time_Period_of_Content:  
Time_Period_Information:  
Single_Date/Time:  
Calendar_Date: 2006  
Currentness_Reference: publication date  
Status:  
Progress: Complete  
Maintenance_and_Update_Frequency: As needed  
Spatial_Domain:  
Bounding_Coordinates:  
West_Bounding_Coordinate: -180.000000  
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East_Bounding_Coordinate: 180.000001  
North_Bounding_Coordinate: 90.000000  
South_Bounding_Coordinate: -90.000000  
Keywords:  
Theme:  
Theme_Keyword_Thesaurus: None  
Theme_Keyword: Imagery, Mosaic, Color, Surface, Global  
Place:  
Place_Keyword: Io  
Temporal:  
Temporal_Keyword: 2006  
Access_Constraints: None  
Use_Constraints: None  
Point_of_Contact:  
Contact_Information:  
Contact_Person_Primary:  
Contact_Person: Dr. Julie Rathbun  
Contact_Organization: University of Redlands  
Contact_Position: Physics Professor  
Contact_Address:  
Address_Type: mailing and physical address  
Address: 1200 East Colton Avenue  
Address: P.O. Box 3080  
City: Redlands  
State_or_Province: California  
Postal_Code: 92373-0999  
Country: USA  
Contact_Voice_Telephone: (909) 793 2121  
Contact_Electronic_Mail_Address: Julie_Rathbun@redlands.edu  
Native_Data_Set_Environment:  
Microsoft Windows XP Version 5.1 (Build 2600) Service Pack 2; ESRI 
ArcCatalog 9.1.0.780  

 
Data_Quality_Information:  

Lineage:  
Process_Step:  
Process_Description: Exported in halves as subsets  
Process_Step:  
Process_Description:  
Georeferenced images by registering corners to extent coordinates points 
produced by custom script  

 
Spatial_Data_Organization_Information:  

Direct_Spatial_Reference_Method: Raster  
Raster_Object_Information:  
Raster_Object_Type: Pixel  
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Row_Count: 5723  
Column_Count: 11446  
Vertical_Count: 1  

 
Spatial_Reference_Information:  

Horizontal_Coordinate_System_Definition:  
Geographic:  
Geographic_Coordinate_Units: Decimal degrees  
Planar:  
Planar_Coordinate_Information:  
Planar_Coordinate_Encoding_Method: row and column  
Coordinate_Representation:  
Abscissa_Resolution: 0.031452  
Ordinate_Resolution: 0.031452  
Geodetic_Model:  
Horizontal_Datum_Name: D_Io_2000  
Ellipsoid_Name: Io_2000_IAU_IAG  
Semi-major_Axis: 1821460.000000  
Denominator_of_Flattening_Ratio: infinity  

 
Entity_and_Attribute_Information:  

Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_1  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_2  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
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Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  
Detailed_Description:  
Entity_Type:  
Entity_Type_Label: Band_3  
Attribute:  
Attribute_Label: ObjectID  
Attribute_Definition: Internal feature number.  
Attribute_Definition_Source: ESRI  
Attribute_Domain_Values:  
Unrepresentable_Domain:  
Sequential unique whole numbers that are automatically generated.  
Attribute:  
Attribute_Label: Value  
Attribute:  
Attribute_Label: Count  

 
Distribution_Information:  

Resource_Description: Downloadable Data  
Standard_Order_Process:  
Digital_Form:  
Digital_Transfer_Information:  
Transfer_Size: 0.000  

 
Metadata_Reference_Information:  

Metadata_Date: 20061208  
Metadata_Contact:  
Contact_Information:  
Contact_Organization_Primary:  
Contact_Organization: University of Redlands  
Contact_Person: Shane Barrett  
Contact_Position: Master's Student  
Contact_Address:  
Address_Type: mailing and physical address  
Address: 1200 East Colton Avenue  
Address: O.O. Box 3080  
City: Redlands  
State_or_Province: California  
Postal_Code: 92373-0999  
Country: USA  
Contact_Voice_Telephone: (909) 522 4792  
Contact_Electronic_Mail_Address: Shane_Barrett@redlands.edu  
Metadata_Standard_Name: FGDC Content Standards for Digital Geospatial 
Metadata  
Metadata_Standard_Version: FGDC-STD-001-1998  
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Metadata_Time_Convention: local time  
Metadata_Extensions:  
Online_Linkage: <http://www.esri.com/metadata/esriprof80.html>  
Profile_Name: ESRI Metadata Profile  

 160


